SpagoBI Meta

SpagoBI Meta is the module specifically focused on metadata management and inquiry. The platform manages technical and business metadata, allowing the user to edit and import them from external tools such as ETL. Business metadata enable the user to know more about the data under evaluation. Technical metadata allow the administrator to know where the data are taken from, to provide automatic documentation or to make impact analyses. SpagoBI Meta is also the basic component for federated inquiry.

The module offers a tool supporting the database reverse engineering process, through which users can define simple and complex objects, to be used within the platform by analysis tools. This module also enriches the knowledge base of SpagoBI Server metadata, so that they can easily be enquired through the already available tools, such as reports, OLAP and QbE. 

SpagoBIMeta1.png SpagoBIMeta2.png

Getting Started ( SpagoBI Meta  )

Please note that this isn't the final product.

A tutorial video can be found here: http://youtu.be/TFmDlMjVqss

How to install SpagoBI Meta

To install SpagoBI Meta just uncompress the downloaded zip into a directory of your choice.
Now locate the "eclipse" directory where you have uncompressed the files and launch the eclipse.exe file to start SpagoBI Meta.
The first thing to do is to select a workspace, or select one already existing, where you want to save the files used by SpagoBI Meta (models,queries,etc...).

selectworkspace.jpg

Create a new DBMS connection

  • To create a new DBMS connection make sure to have opened the "Data Source Explorer" view. For opening this view select the menu Window > Show View > Other > Data Management > Data Source Explorer.

dse.jpg

  • Now inside the Data Source Explorer select "New...", your DBMS Connection type (for example MySql) and click next.

connectionprofile.jpg

  • After that you have to specifiy a Driver and Connection details. If you haven't done this before you have to click on the "New driver definition icon". In this window you have to select the driver version, the driver JAR location (for MySql download it from http://dev.mysql.com/downloads/connector/j/) and the connection properties.

driverdefinition.jpg

driverproperties.jpg

  • With the configured driver now you can test and edit the connection to your database. To test the connection simply press the "Test connection" button, if you get a "Ping succedded" messagge all is working.

pingsuccess.jpg

Create the first Model

To create your first model proceed with this steps:

  • First of all, create a new empty project inside the "Project Explorer" View. Select on the menu bar File > New > Project > General > Project. This will ask you a name for your project and a location (by default inside your current workspace, this is the recommended choice). 

generalproject.jpg

  • Optionally create folder inside your project for every type of resources managed by SpagoBI Meta (models, queries, mappings...) for a better management of your work. For doing this, right-click on a project icon and select New > Folder.
  • Now you can create your first SpagoBI Meta Model. Select on the menu bar File > New > Other > SpagoBI Meta > SpagoBI Model and press next.

newspagobimodel.jpg

  • Assign a name to your SpagoBI Meta Model file (.sbimodel extension), a logic name and select the location inside your project.

spagobimodelwizard1.jpg

  • Next step is the selection of a connection. In this window you can see the connection already definied as described in the previous paragraph. You can also select a Catalog and Schema if avaiable for your database and connection.

spagobimodelwizard2.jpg

  • Now you have to choose the tables to import from your database inside the Physical Model. The Physical Model is like a "snapshot" of your current database tables structure used to create Business objects inside the SpagoBI Model editor.
    Make sure to import all the tables that you want to use later in this step.

spagobimodelwizard3.jpg

  • The last step let you quickly create Business Classes directly from the tables inside the Physical Model. This will create create Business Classes that have an identical structure  (1:1) of your Physical Tables, with foreigns keys converted to business relationships, primary key to business identifiers and columns to attributes.

spagobimodelwizard4.jpg

  • Now click on Finish and You have created your first SpagoBI Meta Model!

Note that after clicking finish the SpagoBI Meta Model editor will be opened. 

  • On the left you have the Business Model representation as a tree, with the Business Classes, Attributes, Business Identifier and Business Relationship. 
  • On the right you have the Physical Model with the original structure extracted from your database connection.

businessmodeleditor.jpg

In the Business Model you can change and combine the structure imported from the Physical Model. Just select the Business Model root or the Business Model Classes to create something new with the context menus. For example you can create new relationships through Business Classes, set new Business Identifiers, delete or rename Business Attributes and combine Business Classes to create composed Business Classes with inherited attributes. You can also do this operations via drag&drop directly from the Physical Model to the Business Model.

businessmodelcontextmenu.jpg

Create the first Query

Once you have created your Business Model, with all the objects that you need, you can query this with the SpagoBI Meta Query Editor. To create a new Query you can:

  • Right-click on the Business Model Root in the Business Model Editor and select Create > New Query
  • Or right-click on a file .sbimodel inside your Project Explorer and select Create > New Query

createquery.jpg

This will open a new wizard that let you create a new Query File (.metaquery) inside your project. The query file store you query definition and will be opened, edited and executed any time. Remember that to query your model the connection to the original database must be alive.

The Query Editor is divided in two tabs (look at the bottom):

  • The Edit tab: let you define and edit the query structure with a simple drag & drop graphical user interface.
  • The Result tab: execute the query definied in the Edit Tab and shows the results in a grid with column sort and pagination.

queryeditor.jpg

In the Edit tab, on the left, you have your Business Model as tree with Business Classes and Business Attributes. Simply drag&drop them to the right panels to compose your query.
queryeditortree.jpg

To the right you can see three panel for: 

  • Select Fields: the fields that will be showed in the results. You can apply alias name, aggregation functions, ordening, group by and more.
  • Where clause: the filtering options that you want to apply to your interrogation. You can choose a left operand, an operation a write a right operand and combine it with another operand usign boolean connector.
  • Having clause: this is similar to the where clause panel but applies to the group by operations.

querypanels.jpg

Tags:
Created by Angelo Bernabei on 2011/05/04 10:06
Last modified by Angelo Bernabei on 2014/10/28 10:29

This wiki is licensed under a Creative Commons 2.0 license
XWiki Enterprise 2.7.33694 - Documentation